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Loudspeaker Free-Field Response  
 

 

This AP shows a simple method for the estimation of the loudspeaker free field response from a set of 

measurements made in normal reverberant rooms.  
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1. Near-Field, Far-Field, Free-Field and Reverberant-Field 
 

When measuring a loudspeaker response we usually denote the measuring conditions as: near field, 

far field, free field or reverberant diffuse field. What does it mean? 

 

To get answer we will have a look at some real measurements of impulse and frequency response.  

 

a) 

Figure 1. Impulse response of a small loudspeaker box, measured in a living room, a few mm near the 

center of loudspeaker membrane.  

 

Fig. 1 shows the near field impulse response of the loudspeaker. It was obtained by placing the 

microphone near the center of loudspeaker membrane. We see a sharp impulse followed by the decay 

of the loudspeaker resonances that lasts a few milliseconds. 
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Fig. 2 shows the far field impulse response of the loudspeaker. It is obtained by placing microphone 

96cm from the center of loudspeaker membrane. We see a sharp impulse followed by the decay of the 

loudspeaker resonances. After a few milliseconds a lot of smaller impulses are following - also with 

their own decay patterns. These impulses come from wall reflections, and are called early reflections. 

The first impulse is called the direct wave. At the tail of the impulse response there is a smooth decay 

pattern without strong impulses. It represents the response of the diffuse reverberation field in which 

a lot of waves hits the microphone from different directions.  

b) 

Figure 2. Impulse response of a small loudspeaker box, measured in a living room, 96 cm in front of 

the loudspeaker membrane 

 

If we make measurements in open space or in a anechoic chamber, with substantial distance from the 

loudspeaker, we say the measurements are done in free field.  

 

We can obtain quasy-free field measurements from a impulse response, that is measured in a normal 

living rooms, if we remove the tail of the impulse response beginning at the first early reflection. The 

remaining part of the impulse response, which is left for the analysis, we call the gated impulse 

response. 

 

Figure 3. Frequency response of a small loudspeaker box, measured in a living room. Measuring 

distances are: 0 cm, 3 cm, 6 cm, 12 cm, 24 cm, 48 cm, 96 cm (from upper to lower curve).  
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Figure 3 shows a frequency response measured in a normal living room at the following distances 

from the loudspeaker: 0cm, 3cm, 6cm, 12 cm, 24cm, 48cm and 96cm. The near field frequency 

response has the smoothest pattern, but with several notches at higher frequencies. At larger measuring 

distances the frequency response has lot of ripples. It is absolutely normal that ripples in a reverberant 

field are larger than 5dB.  

 

 

2. Near-Field to Far-Field Transition in Half Space 
 

To get insight why there are notches in a near field response we take a look on the theoretical analysis 

of the response of a loudspeaker which is mounted in an infinite baffle and radiates into half space (2 

space angle).  

 

Figure 4 shows the normalized sound pressure at the distance r on axis of a circular membrane, which 

has a velocity v. We got it from the solution of the Rayleigh integral for the radiation of a circular disc:     
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a = radius of the membrane, k = wave constant = /c = 2/,  = frequency = 2f ,  

c = speed of sound, o = density of air 

 

We see that in region where the distance r is smaller than 6 times the radius of the membrane the 

sound pressure depends strongly on the directional factor ka = 2a/. For some values of ka and r the 

sound pressure can be zero.  For distance r > 6a the sound pressure is independent of the directional 

factor, and we get the far field response in half space (p2): 
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Figure 4. Normalized loudspeaker response at different frequencies (ka = 1, 5, 10) in a transition 

region from near-field to far-field.   
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In the vicinity of the membrane (r << a) we have a near filed response pN: 
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A near field response has dips at frequencies where ka/2 = /2, 3/2, ..  i.e. at  fn= (2n+1) c/4a.  

In our example, a loudspeaker with a membrane radius a=3.2 cm should have dips in the 

frequency response at 2687 Hz, 8062 Hz and 13437 Hz, nearly as shown in Fig. 2. 

 

The ratio of sound pressures at the distance r in far field to the sound pressure in the near field is: 
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At low frequencies, where ka << 1, sin (ka/2)  ka/2, we can use simplified equation: 

 

( )
r

a

p

rp

NF 2

2 =  

 

 

This expression is important as it is used normally for the transition of the measured near field 

response to the far field response in half space. This expression gives a very small error in the range 

below 200Hz for any practical size of loudspeaker membranes. 

 

The measurement procedure is as follows: 

 

1. Put the measuring microphone a few millimeters in front of the center of the loudspeaker 

membrane / dust cap and measure the near field impulse response.  

2. Scale the impulse response with the factor a/2r to get the half space far field response at the 

distance r.  (ARTA Impulse Response Window - menu command 'Edit->Scale') 

3. Save impulse response under appropriate name. 

 

 

3. Half space to Full Space Free-Field Loudspeaker Frequency 
Response Estimation 
 

A more real case is when the speaker is mounted in a small box and radiates in a full space (4). To 

get more insight, how a small box baffle diffracts acoustical waves, we compare the response of a 

loudspeaker that is mounted in a infinite baffle (p2) to the response a loudspeaker that is mounted in a 

spherical box (p4). 
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Figure 5. a) Loudspeaker with radius a, mounted on an infinite baffle 

b) Loudspeaker mounted in a spherical box of diameter d. 

 

 

A well known analytical solution for the radiation of the spherical loudspeaker box gives us the ratio 

of response in free space (p2) to response in half space (p4): 
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where Cn are Legendre polynomials, Bn and n are magnitude and phase of spherical Bessel functions. 

This solution is valid for on axis radiation (=0). 

 

The evaluation of this expression needs a large computing power, so we define an approximate 

solution. It is of practical interest to analyze the case where the membrane occupies 1/40 to 1/10 of the 

spherical surface (i.e. for angles 0 from 5o to 20o). In that case the on axis response (=0) of the flat 

loudspeaker that is mounted in a spherical box, can be approximated, with an error less than 0.5dB, by 

the expression: 
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with f0  = 42.70 / d  for a spherical box of diameter d or with f0 = 34.16 / d for a box with squared baffle 

of width d. For a rectangular box, that has front baffle width w and height h, ARTA currently uses - as 

an approximation - an equivalent squared box of width d = w (h/w)1/3. 

 

 

This equation defines a "baffle step equalizer". Examples of responses are shown in Fig. 6. 
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Figure 6. Frequency response of a baffle step equalizer for three spherical boxes with diameters of  

0,3 m, 0,5 m and 1,0 m.   

 

Figure 6 shows that at very low frequencies the response in free space is half (-6dB) than the response 

in half space, but it tends to be the same at higher frequencies.  

 

Note: ARTA and STEPS uses the previous expression for the estimation of the diffraction for spherical 

or rectangular baffled boxes. Some CAD and simulation programs are using a high-frequency 

geometrical model for the estimation of box diffraction at low frequencies. Such models can give 

larger errors on low frequencies than the simple model that is presented here. 

 

 

4. Estimation of the Low Frequency Free-Field Response  
 

Now we give the procedure for the estimation of the low frequency free-field loudspeaker response: 

 

1. Measure near-field response and estimate half space response as explained in preceding section,  

i.e. for our speaker with a radius of 3.2 cm, we scale a half-space near field response, to far-field 

half-space response on 48cm, by menu command 'Edit->Scale' and entering the scaling factor a/2r 

into the dialog box 'Pir Scaling';  

 

 
 

 

2. Execute command 'Analysis->Smoothed Frequency response'. Activate in Smoothed FR 

window command 'Overlay->Set as overlay'. You will get following figure:  
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3. Execute menu command 'Edit → LF box diffraction',  to get following dialog box: 

4.  

 

 

 

 

 

 

 

 

 

 

 

Here you should enter the width and the type of 

the box (spherical, squared or rectangular). Now 

you will get the following graph: 
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5. Save this curve as overlay.  

6. Return to PIR window and load loudspeaker response that is measured at the distance of 48cm. Set 

cursor and execute command 'Analyze->Smoothed frequency response'. Finally, you will get the 

following graph: 

 
 

We see that the frequency response measured at 48 cm (black) has high ripple, due to room 

resonances, but generally it is very close to the estimated free-field response (blue). 

 

5. The Estimation of the Wideband Free-field Response 
 

We can make a good estimation of free-field response if we combine the low-frequency near-field 

response and the gated quasi-free-field wideband response. 

 

We start by analyzing the wideband impulse response as shown in Fig. 1. We conclude that we can 

obtain an estimation of the free field response if we remove the first reflection that is 5.6ms apart from 

the start of the impulse response. We make a “gate” in the ARTA PIR window by placing gate marker 

(a red line) just before the first reflection, as in following figure: 

 
 

After execution of the command 'Analysis->Smoothed frequency response' we get the following 

frequency response: 
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We save this curve as overlay. Cursor and yellow line at the bottom of the graph denote that the time-

bandwidth requirement is satisfied on frequencies above 177.9Hz. (Note: 1/gate = 1000/5.604 = 

178.4) 

 

Now we load near-field response, scale it by factor a/2r = 3.2 / (2*48), and calculate frequency 

response, as explained in preceding section. We get: 
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Now we apply LF diffraction correction by the command  

'Edit->LF box diffraction' and following dialog box. 

 

In this dialog we enter box form type  (squared or rectangular 

baffle), box width and box height for rectangular baffle. The 

corrected response and gated response are now closely related. 

 

 

 
 

At 235 Hz both responses have same level so we will choose this frequency as a point for joining the 

two curves. We execute now two commands  

 

1) Edit -> Merge overlay above cursor 

2) Edit -> Delete all overlay 

 

and we get finally the estimation of the free field response: 
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Note: Usually both curves do not match ideally, and additional scaling of 1-2 dB may be necessary in 

practice. 

 

We can save values of this curve with command 'File->Export ASCII'. 

 

 

6. Discussion 
 

For the estimation of the loudspeaker free-field response, from measurements that are done in a 

normal living room, we need following data: 

 

1) effective membrane radius a (a membrane radius plus 1/3 width of the surround) 

2) near-field-response measured at a distance from the center of the membrane less than d < a/20 

3) gated far-field-response measured at distance from membrane d > 6a 

 

The best estimation we get if the gated impulse response is without any wall reflections. It is 

recommended that the gate length should be 5ms or more (dictated with a time-bandwidth requirement 

for correct frequency response estimation on frequencies above 200Hz). Practically this means that for 

a correct measurement setup we must place the microphone at the distance h from the nearest wall or 

floor so that time delay of first reflection would be larger than 5ms.  

 

The following picture illustrates the method of images that help us find the path of wave reflection 

from the floor. We will assume that floor is nearest reflecting surface. 
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From the direct wave path length d and the distance h from floor we get the path length of the first 

reflection   

 

22)
2

(2 h
d

r +=  

 

and the delay of the first reflection     

 

c

dh
d

c

dr
t

−+

=
−

=

22)
2

(2

. 

 

 

Now we can express requirement for the loudspeaker distance from the floor (h) with following 

equation 
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In our case, for the delay of 5ms and d=48cm we get h=1.08m. This means that we must place 

loudspeaker and microphone 1.08m above the floor, to get the  first reflection delay larger than 5ms. 

Of course, the loudspeaker have to be placed distant from all other walls appropriately. 
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